EU - Performance Degraded

Incident Report for NinjaOne Trust

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 10:25 CDT

Update

NinjaOne is aware that service issues continue to affect customer performance. We are continuing our investigation and will provide regular status updates. Please contact Support for additional assistance at support@ninjarmm.com
Posted Mar 04, 2026 - 16:56 CST

Update

We've completed maintenance and will continue to monitor. Thank you for your patience.
Posted Mar 04, 2026 - 16:56 CST

Update

We will be performing maintenance in this region to bring online additional capacity for our Agent services. As part of this work, we need to restart all Agent endpoints at the conclusion of the maintenance. Ninja Agents will disconnect and reconnect automatically during this restart, and any data local agent collected during the disruption will be stored locally and resent when the agent reconnects to our servers. We will continue to provide updates accordingly. Thank You
Posted Mar 04, 2026 - 14:05 CST

Update

NinjaOne is aware that service issues continue to affect customer performance. We are continuing our investigation and will provide regular status updates. Please contact Support for additional assistance at support@ninjarmm.com
Posted Mar 03, 2026 - 01:00 CST

Monitoring

We've completed maintenance and will continue to monitor. Thank you for your patience.
Posted Mar 02, 2026 - 20:42 CST

Update

We are currently verifying the results of this maintenance. We continue to monitor the situation in the region accordingly. thank you.
Posted Mar 02, 2026 - 18:02 CST

Update

We are continuing the final phases and validating the changes made with this maintenance. We will continue to provide updates accordingly. Thank you.
Posted Mar 02, 2026 - 16:07 CST

Update

The Maintenance is still in progress. We will send continued updates on progress and upon completion. Thank you.
Posted Mar 02, 2026 - 15:18 CST

Update

In response to the evolving situation, we are performing maintenance on our database backend systems that support our Agent Reporting Services. As we perform that maintenance, Agents will be disconnected for approximately 10 mins and will automatically reconnect at the end of the maintenance. As a reminder, your data is locally saved during this time and all data will be sent once your connection is reestablished.

These changes are one part of overall improvements we are making to address the current stability issues in the region. Thank you for your continued patience. We will update you again soon.
Posted Mar 02, 2026 - 13:55 CST

Update

We have temporarily disabled Full Text Search in our Ticketing service. We don't believe this to be root cause, but is contributing to increased load on the database. We plan to re-enable after we continuing working to mitigate the broader stability issues.
Posted Mar 02, 2026 - 05:56 CST

Update

We are seeing Ninja Remote metrics indicate the service is returning to a healthy state, however we are continuing to experience page load timeouts and intermittent delays in the UI. We are working on stabilizing these components currently.
Posted Mar 02, 2026 - 04:35 CST

Update

We are continuing to investigate this issue.
Posted Mar 02, 2026 - 03:10 CST

Investigating

NinjaOne has identified a service issue that may affect customer performance. We are currently investigating and will provide regular status updates. Any customers having issues with the Ninja Application can contact Support for assistance at support@ninjarmm.com.

Thank you for your patience.
Posted Mar 02, 2026 - 02:08 CST
This incident affected: United States (US), Europe (EU), Australia (OC), and Canada (CA).