Twilio & MFA Service Issue - Performance Degraded
Incident Report for NinjaOne Trust
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 09:28 CDT
Monitoring
Update from Twilio:
We are continuing to monitor remaining queued messages. Overall, the system has reached a normal steady state; Now, most messages are sending without any additional queueing delay. However, individual customers may see messages remaining in queues due to large numbers of messages enqueued during this incident. We expect any messages delayed during this incident to have fully propagated through to a final status over the course of the next several hours. Note that we expect that some messages will eventually timeout and fail due to Validity Period Expired (error code 30036), others may eventually fail due to a Twilio Internal Error (error code 30500).
Posted Mar 26, 2024 - 09:24 CDT
Identified
Twilio status page shows a service outage https://status.twilio.com/ meaning that SMS and MFA for NinjaOne will not be delivered as expected.
Posted Mar 26, 2024 - 09:05 CDT
Investigating
We are aware of some performance related issues with some components of the Ninja platform and are currently investigating.
Posted Mar 26, 2024 - 08:51 CDT
This incident affected: United States (US2).