TeamViewer Connectivity Errors

Incident Report for NinjaOne Trust

Postmortem

We have confirmed with the TeamViewer support team that there was an issue with the SSL Certificate on their API endpoint. This resulted in NinjaOne rejecting/failing API requests due to SSL Validation errors, resulting in connection failures/elevated error rates. After the SSL issue was resolved on TeamViewer’s environment, we saw functionality restored and our error rates return to normal levels.

Posted Jul 22, 2025 - 12:12 CDT

Resolved

This incident has been resolved.
Posted Jul 22, 2025 - 11:34 CDT

Monitoring

We have seen the TeamViewer connection error rates drop to zero. We are engaging with TeamViewer to determine root cause.
Posted Jul 22, 2025 - 10:54 CDT

Investigating

We are aware of an issue with TeamViewer connections failing to start/connect. We are currently investigating the issue.
Posted Jul 22, 2025 - 10:08 CDT
This incident affected: United States (US), Europe (EU), Australia (OC), Canada (CA), and United States (US2).