Verification is currently underway for the maintenance items.
Posted Apr 01, 2026 - 14:54 CDT
Update
NinjaOne is finalizing the OC release soon, with only a handful of services remaining to deploy. No customer impact is expected as these services are upgraded, however agents will automatically upgrade post-release and customers may experience a brief disconnect while they restart post-upgrade. No data loss or other service disruptions are anticipated at this time.
Posted Apr 01, 2026 - 14:22 CDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Apr 01, 2026 - 14:18 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2026 - 09:09 CDT
Scheduled
We will be undergoing scheduled maintenance.
Posted Mar 31, 2026 - 09:49 CDT
This scheduled maintenance affected: Australia (OC).