Dropsuite performance degradation for EU hosted service

Incident Report for NinjaOne Trust

Resolved

This incident has been resolved.
Posted Jul 09, 2026 - 16:31 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2026 - 15:18 CDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 09, 2026 - 15:08 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 09, 2026 - 13:21 CDT

Investigating

We are currently investigating reports of degraded performance affecting some users in the EU region. Other regions may experience intermittent impact. Our team is actively working on a resolution. We will provide updates as more information becomes available.
Posted Jul 09, 2026 - 12:37 CDT
This incident affected: Europe (EU).