CA - Splashtop Icons Not Showing For New Devices

Incident Report for NinjaOne Trust

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 13:44 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2025 - 13:27 CST

Investigating

We are aware of an issue causing the Splashtop icon to not appear on newly added devices. We are actively investigating this matter to identify the root cause and implement a solution as soon as possible.
Posted Nov 12, 2025 - 05:29 CST
This incident affected: Canada (CA).