EU - Latency issues in Backup Web UI

Incident Report for NinjaOne Trust

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 15:42 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 05, 2025 - 12:58 CDT

Investigating

We are currently experiencing some latency and intermittent issues in the web UI for our backup products. Backup schedules and jobs remain unaffected. We are working to resolve this issue.
Posted Sep 05, 2025 - 10:48 CDT
This incident affected: Europe (EU).