NA Service Issue - Performance Degraded
Incident Report for NinjaOne Trust
Postmortem

As a part of the 5.8.0.20 release, NinjaOne introduced several performance and architectural enhancements to our WAMP service. We deployed these changes successfully to all of our regions, however in NA we experienced erratic performance with our underlying cloud provider. To alleviate the customer impact, the NinjaOne team scaled out the WAMP service and are actively working with our Cloud Provider to identify and remediate the cause of the instability.

Posted May 03, 2024 - 12:52 CDT

Resolved
This incident has been resolved.
Posted May 02, 2024 - 12:10 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 11:23 CDT
Update
We are applying a revised fix shortly - this may result in poor performance in remote tools and real time services for a short period of around 5 minutes.
Posted May 02, 2024 - 10:56 CDT
Update
We are continuing to work on a fix for this issue.
Posted May 02, 2024 - 10:25 CDT
Update
We will shortly cause a brief interruption to the ninja remote tools and realtime services in order to apply a change which we hope will resolve this connection issue in full.
We estimate this outage will last for between 5 and 15 minutes.
Posted May 02, 2024 - 09:59 CDT
Update
We are continuing to work on a fix for this issue.
Posted May 02, 2024 - 09:39 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 02, 2024 - 09:00 CDT
Update
We are continuing to investigate. It appears that remote tools are currently affected.
Posted May 02, 2024 - 08:49 CDT
Investigating
We are aware of some performance related issues with some components of the Ninja platform and are currently investigating.
Posted May 02, 2024 - 08:25 CDT
This incident affected: United States (US).