Ninja/Dropsuite SSO Navigation Broken & Organizations Unlinked Following Recent DS Update

Incident Report for NinjaOne Trust

Resolved

Ninja/Dropsuite SSO Navigation has been restored.
Posted Nov 06, 2025 - 13:03 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 12:01 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 06, 2025 - 11:35 CST

Investigating

We are investigating an issue affecting the Ninja SaaS Backup integration where the Single Sign-On (SSO) link to the Dropsuite portal is temporarily unavailable. Customers should use direct sign-in to the separate Dropsuite portal for continued access.
Posted Nov 06, 2025 - 11:18 CST
This incident affected: United States (US), Europe (EU), Australia (OC), Canada (CA), and United States (US2).