SaaS Backup Portal Issues

Incident Report for NinjaOne Trust

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 16:35 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 29, 2026 - 14:39 CST

Identified

We're investigating reports of UI access issues when navigating from the NinjaOne Portal to our SaaS Backup Portal. We've confirmed that all backups are still running, and this is isolated to navigation in the UI only.
Posted Jan 29, 2026 - 14:17 CST
This incident affected: United States (US) and Canada (CA).