Public API endpoint issue: devices-detailed

Incident Report for NinjaOne Trust

Update

We are continuing to monitor for any further issues.
Posted Apr 16, 2026 - 13:14 CDT

Monitoring

A hotfix has been deployed and we are currently validating the change.
Posted Apr 16, 2026 - 11:42 CDT

Identified

We expect to have a hotfix ready and deployed within the next two hours. This will result in a brief disruption of the API while we apply the hotfix, but it is expected to be brief
Posted Apr 16, 2026 - 10:23 CDT

Investigating

Known issue with the devices-detailed Public API endpoint now requiring pagination. We are working on rolling back this change. Until it is fixed customers can access all devices using the pageSize and after query parameters.
Posted Apr 16, 2026 - 07:35 CDT
This incident affects: Europe (EU), Australia (OC), Canada (CA), and United States (US2).