Mitigation efforts have shown positive results and we are seeing agents reporting status correctly at this time. We are continuing to monitor the incident.
Posted Jul 24, 2026 - 15:10 CDT
Update
To help mitigate some agents still showing offline we are restarting our frontend web systems. Some users may see a slight increase in response time during this process.
Posted Jul 24, 2026 - 13:21 CDT
Update
During the AWS Outage, Ninja Agents attempted and failed to reconnect to our backend services. This automatically triggers a backoff/retry mechanism in our agents that is designed to prevent traffic flooding or thundering herd behavior during significant outages. Agents are slowly reconnecting, but will randomize their reconnection attempts until successful. Additionally the service that was responsible for processing device status was struggling with the volume of agent status changes. We have scaled that capacity out and are seeing healthy metrics. Over the last hour we have seen our connected devices increase by over 150k devices, but recovery will likely be slow while the agents attempt to gracefully reestablish service
Posted Jul 24, 2026 - 10:38 CDT
Update
We are continuing to monitor for any further issues.
Posted Jul 24, 2026 - 09:54 CDT
Monitoring
We have identified a broader connectivity issue within our cloud provider's infrastructure that is causing intermittent service disruptions for some customers. Recovery efforts are ongoing and service stability has improved, though some impact may persist while restoration work continues.
Posted Jul 24, 2026 - 08:08 CDT
Identified
We have identified a broader connectivity issue within our cloud provider's infrastructure that is causing intermittent service disruptions for some customers, and we are actively monitoring recovery efforts.