NA Region Degradation
Incident Report for NinjaOne Trust
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 09:30 CST
Monitoring
At 14:02 UTC an issue affecting NA performance was identified, the issue was resolved at 14:27 UTC, we'll continue monitoring
Posted Nov 21, 2022 - 08:56 CST
This incident affected: United States (US).