Agents Reporting Offline and Remote Tools issue in NA
Incident Report for NinjaOne Trust
Postmortem

On 3/15 we introduced several planned changes to our backend Agent service. One of these changes introduced a higher-than-expected load on a different service causing significant delays or timeouts when interacting with our agents on Monday 3/22

We quickly scaled these resources to address the increased load and monitored the environment over the next several hours to ensure services were operating normally. Additional monitoring and alerting have been added, based on these findings, to detect this issue proactively in the future.

Posted Mar 22, 2023 - 13:18 CDT

Resolved
This incident has been resolved.
Posted Mar 20, 2023 - 15:10 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2023 - 14:28 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 20, 2023 - 13:20 CDT
Update
We are continuing to investigate this issue, we identified that this is also affecting remote tools
Posted Mar 20, 2023 - 12:57 CDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2023 - 12:18 CDT
Update
We are continuing to investigate this issue.
Posted Mar 20, 2023 - 11:54 CDT
Investigating
We are investigating an issue with agents reporting offline in NA, we will provide regular status updates, any customers having issues with the Ninja Application can contact Support for assistance at support@ninjarmm.com
Posted Mar 20, 2023 - 10:23 CDT
This incident affected: United States (US).